Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

cannot get openssl to work
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Apache
View previous topic :: View next topic  
Author Message
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Sun Mar 20, 2005 7:32 am    Post subject: cannot get openssl to work  

I do not know how to work with virtual hosts. I just want to get ssl to work form my domain name or ip address. In ssl.conf if it is set like this

<VirtualHost _default_:443>
ServerName
then ssl works, but only if I call it from hhtps://localhost/. I want to either get it to work if I call my web page from my ip or my domain name. I prefer to call the web page from my domain name but I would also like to know how to let it work from my ip too.

My certificate servername or commonname is I think my problem is that I do not know how to setup virtualhost in my ssl.conf.

Any help would be appreciated.
Back to top  
door33



Joined: 28 May 2004
Posts: 67
Location: US

Posted: Sun Mar 20, 2005 8:21 am    Post subject:  

this might help you
http://apache2triad.net/forums/viewtopic.php?t=1259
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Sun Mar 20, 2005 6:56 pm    Post subject:  

I cannot get it to work. I folllow the directions from that link and many more on the internet.
Back to top  
door33



Joined: 28 May 2004
Posts: 67
Location: US

Posted: Sun Mar 20, 2005 7:15 pm    Post subject:  

yea it might be your isp blocking ports change the port to listen of a differnt one and see if that works if so thats the problem and make sure you have the apache2ssl services running
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Sun Mar 20, 2005 8:31 pm    Post subject:  

ssl services is running. I will give that a try
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sun Mar 20, 2005 8:46 pm    Post subject:  

dyndns forwards just your ip address. Any port calls are transferred the same way so a request to yoursitename:443 goes to youripaddress:443

BTW, did you check to see if your firewall and/or router has port 443 open? (If you use XP make sure it's firewall is configured too)
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Sun Mar 20, 2005 10:14 pm    Post subject:  

Ok, now that I know that dyndns.org will foward my ports for my domain
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sun Mar 20, 2005 11:30 pm    Post subject:  

In theory that setup should work. However, I'd also wager that if you isp would allow port 80 that they wouldn't block port 443. Try setting it up using port 443 and try to access it using https.
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Mon Mar 21, 2005 1:41 am    Post subject:  

Well, I tried the setup abobe like I had said and it does not work for my port 512 if I set it up for that, but it also did not work for port 443 which I had it setup for prior to now. Yea, my server is on my personal pc until I learn how to do this stuff so i tend to turn it off when I am not using it, thats why it would not respond for you.
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Mon Mar 21, 2005 3:06 am    Post subject:  

Do you have the apache with ssl service running?
To check it go to start -> run -> services.msc

If you want to keep is simple you can uninstall, and re-install A2T and use a little batch script I made to create a self signed certificate, and enable ssl for Apache2Triad. http://jaydium.servehttp.com/download.php?view.11
It's nothing fancy I just took the steps mentioned in a thread from these forums, and put it into a batch script.
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Mon Mar 21, 2005 7:07 am    Post subject:  

Yes, the apache ssl service is running it starts by default. I put the server and router back to answer to port 443 like it should. I downloaded Curl and tried
Back to top  
billy



Joined: 20 Mar 2005
Posts: 7

Posted: Mon Mar 21, 2005 10:21 am    Post subject:  

I got it to work. I had it all setup for port 443 and it would not work so I set it up for port 512 to test it and it would not work. I finally figured out that when I changed it to port 512 from 443 that my router had not made the changes. I had decided to do a online port check for port 512 and then I learned it was not responding so I rebooted my router and now it works. Later I will see if it will work on 443 or not then I will know for sure if my ISP blocks it. Thanks for all the help though.


I have had time now to try port 443 and it is not blocked by my ISP. My problem all along was that when I created a rule in my firewall to monitor port 443 that it would not work unless I had rebooted the router for it to take affect.
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Apache
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group