Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

Apache service wont start.
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Apache
View previous topic :: View next topic  
Author Message
nullmind



Joined: 10 Mar 2005
Posts: 4

Posted: Fri Mar 11, 2005 4:11 pm    Post subject: Apache service wont start.  

I had a character encoding problem yesterday and even after editing .htaccess file, it was unsuccessful. I kept pressing f5 for refresh and suddenly apache service shutdown. I reboot and still apache service wont automatically load. I tried starting the service manually and I got error message "Windows could not load Apache2Triad Apache service blah blah so check your system event log. Error code 1".

These are just some of the logs that I "think" are relevant to the problem.
I get this everytime I try to start the apache service.

10:49:35am The Apache2Triad Apache2 Service service was successfully sent a start control.
10:49:35am The Apache2Triad Apache2 Service service entered the stopped state.
10:49:35am The Apache2Triad Apache2 Service service terminated with service-specific error 1 (0x1).

P.S. I dunno why but httpd.conf file is 0kb while httpd.default.conf file is 34kb. Is that normal or should I rename the files?


UPDATE: I deleted the 0kb file and made a copy of httpd.default.conf and renamed to httpd.conf and tried running apache. I got this error message
"apache.exe: Could not determine the server's fully qualified domain name, using 192.168.0.100 forServerName"

The service still wont start but wierdly control panel works now.

UPDATE2: Lol.. This is bs. After I got in the apache2triadCP, I closed the error msg window and the a2tCP stopped working. I thought it was wierd and opened a2t server monitor and tried starting the service. Service started without hesitation. I can see now httpd.conf being 0kb was the problem but why did it work before and suddenly stopped working and why did httpd.conf turned to a blank file?

UPDATE3: Ok. I noticed problems with PHP now. When I try to navigate the control panel I just get plain text and codes instead of php loading properly. Correct me if I'm wrong but I think I remember seeing

Apache/2.0.52 (Win32) / PHP 5.x.x

Something like that in the description on the apache service but now I only see

Apache/2.0.52 (Win32)

I could just delete/reinstall but I want to try to solve the problem :cry:
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Fri Mar 11, 2005 11:37 pm    Post subject:  

all your problems seems to have been caused by the outstanding apache2triad 1.5.1 editor.php bug http://apache2triad.net/forums/viewtopic.php?t=902

i am sorry but i will have to suggest a reinstall and a manual patch of the bug acording to that post
Back to top  
nullmind



Joined: 10 Mar 2005
Posts: 4

Posted: Sat Mar 12, 2005 4:28 am    Post subject:  

Thanks. Don't have to be be sorry, I'm happy this came up. This was a good learning experience.
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Apache
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group