Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

Site Only Shows on localhost.
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Networking
View previous topic :: View next topic  
Author Message
Da_Thing



Joined: 24 Sep 2005
Posts: 5

Posted: Sat Sep 24, 2005 3:07 am    Post subject: Site Only Shows on localhost.  

I cant get my site to load on blocklandclub.no-ip.info. why? it only shows on localhost I am use XP.
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sat Sep 24, 2005 8:19 pm    Post subject:  

Make sure that your firewall, and router have the appropriate ports open/forwarded to your host computer.

Also, I assume your using no-ip's software to update your DNS to your ip.
Back to top  
Da_Thing



Joined: 24 Sep 2005
Posts: 5

Posted: Sat Sep 24, 2005 11:38 pm    Post subject:  

Demoric wrote: Make sure that your firewall, and router have the appropriate ports open/forwarded to your host computer.

Also, I assume your using no-ip's software to update your DNS to your ip.

yes i use the updater Here is some info

blocklandclub.no-ip.info 70.17.46.124:80
Quote:
Server running Apache/2.0.54 (Win32) PHP/5.0.4
Server bound on 127.0.0.1 : 80
Server admin addr admin@blocklandclub.no-ip.info
Server webroot C:/apache2triad/htdocs
Local Time 07:47:57 PM Saturday 24.09.2005
Logged in user root
Client proxy (none)
Client address 127.0.0.1
Client port 4690
Access server via localhost

Quote: C:\WINDOWS/php.ini line 601 good (blocklandclub.no-ip.info)
C:/apache2triad/conf/httpd.conf line 1149 good (blocklandclub.no-ip.info)
C:/apache2triad/conf/httpd.conf line 1150 good (blocklandclub.no-ip.info)
C:/apache2triad/conf/ssl.conf line 89 good (blocklandclub.no-ip.info)
C:/apache2triad/conf/ssl.conf line 90 good (blocklandclub.no-ip.info)
C:/apache2triad/htdocs/uebimiau/inc/config.php line 47 good (blocklandclub.no-ip.info)
C:/apache2triad/htdocs/uebimiau/inc/config.php line 158 good (blocklandclub.no-ip.info)
C:/apache2triad/htdocs/uebimiau/inc/config.php line 159 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/domains.tab line 1 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/mailusers.tab line 1 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/mailusers.tab line 2 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 1 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 2 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 3 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 4 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 5 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 6 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 7 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/server.tab line 8 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/domains/blocklandclub.no-ip.info/admin/user.tab line 1 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/domains/blocklandclub.no-ip.info/admin/user.tab line 2 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/domains/blocklandclub.no-ip.info/postmaster/user.tab line 1 good (blocklandclub.no-ip.info)
C:/apache2triad/mail/domains/blocklandclub.no-ip.info/postmaster/user.tab line 2 good (blocklandclub.no-ip.info)
C:/apache2triad/htdocs/awstats/awstats.blocklandclub.no-ip.info.conf line 148 good (blocklandclub.no-ip.info)

Zpanel says this:

Checking services on:

HTTP: PORT 80 = *
FTP: PORT 21 = *
SMTP: PORT 25 = *
POP: PORT 110 = *
MySQL: PORT 3306 = *

They are all down.
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sun Sep 25, 2005 2:24 pm    Post subject:  

You have your server bound to localhost only.

Open your httpd.conf file and find the listen 127.0.0.1:80 and change it to *:80 (or if you have a static ip change it to that ip address)

Also, you didn't say if you checked your pc's firewall, and router (if you use one) to see if those ports are open.
Back to top  
Da_Thing



Joined: 24 Sep 2005
Posts: 5

Posted: Sun Sep 25, 2005 5:53 pm    Post subject:  

it is at *:80 and my firewall is allowing port 80 And i cant access the DSL router it comes up as localhost :?
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sun Sep 25, 2005 8:01 pm    Post subject:  

Try accessing your router from:

//192.168.1.1
or
//172.16.0.1
or
//10.0.0.1
Back to top  
Da_Thing



Joined: 24 Sep 2005
Posts: 5

Posted: Sun Sep 25, 2005 8:05 pm    Post subject:  

Ok just found out what it is, all the connections are filtered. How do i fix that. I am using westell 2200
Back to top  
Valareos



Joined: 29 Oct 2005
Posts: 16

Posted: Sat Oct 29, 2005 4:59 pm    Post subject:  

hey Da_thing. Let me help ya out here, mainly cause I found the answer to my question by searching :P (thanks Demoric)

Ok log on to your router, and look for a group of settings for Fowarding (may be under advanced) you want to activate 80 and then put the ip address as your internal address of your server.

This is what will happen.

Lets say your router's ip address it recieved from your DSL company is 200.100.10.10 and your internal address of your server is 192.168.1.2 When an outside source tries to go to blocklandclub.no-ip.info it will go to 200.100.10.10:80 By activating the fowarding, you just told your router that anything coming in on port 80 (standard http port) externally will be redirected to 192.168.1.2:80 internally thus allowing your customers to access your server. (you would use the same sort of setup if you got a firewall)
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Networking
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group