Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

problem with phppgadmin affecting apache server
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
View previous topic :: View next topic  
Author Message
hanman



Joined: 28 Jun 2006
Posts: 3

Posted: Wed Jun 28, 2006 3:52 am    Post subject: problem with phppgadmin affecting apache server  

since i found apache2triad, i've been a extremely satisfied...this bundle is incredible! thanks for providing it for us!

I'm running into a weird problem though. I'm a supporter of PostgreSQL (another reason why i love apache2triad). A couple days ago, after having 1.5.4 installed for a few months (to try out php5), i tried using phppgadmin to make changes to my postgresql database. I added a new user and was going to create a new table, when the admin interface stalled (parts of the screen were not refreshing, server was hanging (it seemed)). I should note that i was accessing the admin from a remote computer through a router (which has been configured and tested properly). When i got home and checked apache2triad monitor, it showed that apache service was started, but i couldn't access my sites locally. I checked the services and saw it was off, i had to restart it. every other service, including postgresql, was unaffected, just apache2triad, and only after using phppgadmin. It happened again today. This problem does not happen when i use pgadminIII.

Another problem, perl.exe seems to be hanging and consuming CPU resources without the results (i went to use apache2triadcp to check the error log and such, and when i clicked on something calling a .cgi script, the server would hang and the task manager showed perl.exe at 70% min). I should note that when i ran the perl test from the control panel, everything seemed to be ok. the problem seems to be occurring when i run the check error log script or other cgi perl scripts.

I'm running the servers with the following config
AMD64 3400
1.17GB RAM
XP Pro SP2

Any help would be greatly appreciated,

Haneef
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Fri Jun 30, 2006 8:10 am    Post subject:  

might be because of the CPU
All binaries are compiled for a x86 and tho AMD64 is x86 backwards compatible problems do arise.
I have seen reports about mysql hang on AMD64 and it is probable that this version of perl does too (only cgi perl scripts use perl.exe , .pl files run under mod_perl)
Back to top  
cigraphics



Joined: 21 Aug 2005
Posts: 148
Location: Romania, Pitesti

Posted: Fri Jun 30, 2006 2:52 pm    Post subject:  

i have AMD ATHLON 64 3000+ and Win XP SP2 with 512 DDR and i have no problems :) everything is working fine
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group