Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

MYSQL backslash config bug
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
View previous topic :: View next topic  
Author Message
lappies



Joined: 24 Jul 2006
Posts: 2

Posted: Mon Jul 24, 2006 5:55 pm    Post subject: MYSQL backslash config bug  

Battling now 3-4 days and nearly 60 hours to get MYSQL working but my African patience are drying up... while trying to get it going with the help of apache2triad1.4.4.exe

Install and uninstall the package 4 times now.
Problems eliminated:
 Eliminated my firewall Zonealarm even virus (AVG)
 Downloaded Fport.exe so there is not a clash of ports any more.

Still Cannot get MYSQL service started
Ask for a username and password (root and the global password does not work even root and nothing)
To change the password is not working because the file mysqld-nt does not exists in MYSQL 4.? Only in 5
(SET PASSWORD FOR 'root'@'localhost' = PASSWORD('MyNewPassword');) and
At the DOS command prompt, execute this command:
C:\> C:\mysql\bin\mysqld-nt --init-file=C:\mysql-init.txt

Can install MYSQL 5 with installer separately and then it is running at the right port and even passwords but then phpMYAdmin is still not working from apache2triad install
Can still not run the apache2trais MYSQL service because of error 1058 because it does not have one of its enableing devices associated with it.
My conclusions:
I am not sure if there was a MSQL db previously installed but it was without my knowlwdge.
(I looked through my comp but no trace of PREVIOUS MYSQL installs.)
However I am a total newbie to PHP, MYSQL and apache etc so I suppose this is the learning curve if you want to go this non Microsoft route!
I just want to try out a Drupal/civicspace CMS package and expect to spend much time there


O Yes the errors started at installation here at. (cannot get past this one)

C:\support\apache2triad/mysql/bin/mysqladmin.exe: connect to server at 'localhos
t' failed
error: 'Can't connect to MySQL server on 'localhost' (10061)'
Check that mysqld is running on localhost and that the port is 3306.
You can check this by doing 'telnet localhost 3306'
Password for Mysql not changed !!
Automatically using MD5 format.
Adding password for user root

Then with password renaming it gives at the MYSQL part (Beacsue mysql is not running)

We were unable to set the password 1 times ,
Report this to apache2triad.net
(Do not post screenshots , copy/paste the text intead) Press enter to exit

I am running win2000 OS
Had IIS running as well all the time.
Later disable it
Install MYSQL5 in the place of the bundled one and it started to work.
Then in one way or another phpmyadmin started to work after tweaking the config file but still did not want to add a user.

Any suggestions what could be wrong?
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Sat Jul 29, 2006 8:23 am    Post subject:  

if your logic matches your patience you are sure to get it right eventually

apache2triad uses a unified mysqld , no mysqld-nt so that should not be a problem , the problem is that in apache2triad mysql is not installed in root but under apache2triad/ , and that mysqld-nt --init-file=C:\mysql-init.txt is not a apache2triad command

apache2triad stable releases are configured for mysql 4 , many things will not work if you replace it with mysql 5

just stick with a edge or stable apache2triad or not use it at all and install everything yourself , compromises will be frustrating
Back to top  
lappies



Joined: 24 Jul 2006
Posts: 2

Posted: Mon Jul 31, 2006 5:10 am    Post subject:  

You were so right just a good nights sleep and more patience.
My success was to stay with the basic install - otherwise I comprimise too much

Eventually after uninstalling EVERYTHING and started from scratch I have the solution for my setup now...

All was working except MYSQL and what was runnig on it like phpmysqladmin etc.

My final attemp were:
(1) I rename the my.ini file in WINNT dirrectory so there was NO my.ini file.
(2) Then fire up winmysqladmin.exe in the apache2triad'/mysql/bin and then get it via the hide icon to go to the systray and form there I use the right click there then win NT then start service.
(3) THEN MYSQL was running the right version etc from basic apache2triad install. This method created a new my.ini file in WINNT and most was working now except that i had to change passwords back to the apache2triad installs ones.
(4) I then compare the renamed my.ini from the original basic install with the new one and all that I really could see a difference is that in he original file there was a mixture between forward and backslashes in the different path s to some of the MYSQL directories.
(5) I changed All the back slaches\ to / forward slaches RIGHTTHROGH this file with search and replace and put the old one back . and BINGO it was and still is working like it should.

SO in my experience - THE SHORCUT route
If the MYSQL is not running - that means phpadmin mysql etc
then go to the WINNT folder open the my.ini file and replace all the backslaches\ with forward slaches/ . restart then Bingo it is working

Man an I now inpressed with this LAMP and also apache2triad install that integrate all and work without me need to know too much of php and all the rest.. I am using it for a few days now and started to investigate the CMS application that I need it for.

I do not wanna know how much time did went into this install ... just got a lot of respect for you guys out here and thanks for all your hard work. Nothing like opensource....

If my tip can help others it would be a pleasure adding to this knowledge base.[/quote]
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group