Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

Can only access home page from Internet.
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Networking
View previous topic :: View next topic  
Author Message
dalem



Joined: 02 Sep 2006
Posts: 2

Posted: Sat Sep 02, 2006 11:43 am    Post subject: Can only access home page from Internet.  

Hi !

I have apache2triad 1.5.4 installed on Windows XP Pro.
I use Zonedit to redirect to my IP address.
Installation of apache2triad was fine with no errors, I can connect to MySQL, PhpMyAdmin, etc. etc.
I changed my domain in control panel to point to my website IP.
I copied my website to apache2triad/htdocs and tried to access it from my browser.
My browser can open my website but as soon as I try to browse my site it changes from "Internet" to "localhost". It seems to be stuck on a loop somewhere always pointing to localhost.
Localhost works just fine but not from the Internet.
I have asked friends to try and view my site and they also get the same problem. They can see the homepage (which is index.php) but as soon as they try browsing other pages they get error messages like "can't connect to localhost"

I have tried to sort this out myself and have looked on the FAQ and Forums for answers but without success.

Please can someone help.

Thank you.

Dalem.
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Sun Sep 03, 2006 2:15 am    Post subject:  

Verify your links, (if you are using a script verify your site's address that might be used to create the home of the url of your links)
Back to top  
dalem



Joined: 02 Sep 2006
Posts: 2

Posted: Sun Sep 03, 2006 10:24 am    Post subject: Joshua Meadows  

Hi.

Thanks for your reply.
I have not used any scripts to configure my url. The only place I changed my url was from Control Panel "Change Domain"
Sorry if I am a bit vague on this issue. This is quite new to me. I try to sort out my own problems first but I can't seem to find any solution. I just don't know where to start looking.
I really like apach2triad and would like to have it working correctly.
I would really appreciate if you could point me in the direction of a fix to my problem.

Sincerely.

Dalem.
Back to top  
Joshua Meadows (DemoRic)



Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

Posted: Wed Sep 06, 2006 10:00 pm    Post subject:  

What is your site's url?
Also, make certain that your firewall has the correct ports open.
Back to top  
erilidon



Joined: 08 Jun 2006
Posts: 4

Posted: Sat Jun 30, 2007 12:15 am    Post subject:  

what type of connection do you have? i.e. cable, dsl? Like they said, check you firewall and also if your run through a router check the port forwarding settings on that as well.
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Networking
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group