Apache2Triad Help, Support and Development Forum Index Apache2Triad Help, Support and Development
The apache2triad help , support and development forums
 

Apache won't start, no error log messages
Click here to go to the original topic

 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
View previous topic :: View next topic  
Author Message
watchorn



Joined: 09 Mar 2007
Posts: 3
Location: Canada

Posted: Fri Mar 09, 2007 5:34 pm    Post subject: Apache won't start, no error log messages  

I've read the FAQs and the forums, but I still can't figure out why the Apache2 service doesn't start.

Apache Monitor says that it is starting, but that's appears to be simply stating that is trying to start it, not that it actually IS starting.

I get no message in c:\apache2traid\logs\error.log the file is empty.
MySQL, PgSQL, Xmail, and SlimFTPd all start without any problems.

When I run httpd -t from the command line I get this error in a popup window:

httpd.exe Entry Point Not Found
The procedure entry point mysql_stmt_prepare could not be located in the dynamic link library LIBMYSQL.dll

I tried commenting out LoadFile C:/apache2triad/mysql/bin/libmysql.dll from the httpd.conf file but it had no effect.

When I run apache -t from the command line I get this error:

'apache' is not recognized as an internal or external command, operable program or batch file.

This is worrisome because it appears the system can't find the apache program. Where should I be looking to make sure it is there? The apachemonitor file is in the apache2triad folder, as is httpd. So could there be something else missing?

Win32DisableAcceptEx is currently not commented out.

I ran netstat (see attached mynetstat.txt file) and port 80 is free, so that shouldn't be the problem.

Here are the error messages I got from the Event Viewer:


Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7009
Date: 3/9/2007
Time: 11:29:24 AM
User: N/A
Computer: WATCHORN
Description:
Timeout (30000 milliseconds) waiting for the Apache2Triad Apache2 Service service to connect.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


The Microsoft website was not helpful
-------------------------------------------------------------------------------------------------------------------------------------------------------


Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7000
Date: 3/9/2007
Time: 11:29:24 AM
User: N/A
Computer: WATCHORN
Description:
The Apache2Triad Apache2 Service service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Again, the Microsoft website was not helpful.

I have tried reinstalling many [many] times, so that's not a valid suggestion.

I have uninstalled GIMP and Skype, to remove those as possible causes of the problem.
I have it working on an XP Media Center laptop beautifully, but so far no luck with my XP Pro system.

I tried swapping in the httpd.conf file that works (from my laptop) to the non working XP Pro system, but that didn't change anything, apache still won't start.
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Fri Mar 16, 2007 12:48 pm    Post subject: Re: Apache won't start, no error log messages  

watchorn wrote: httpd.exe Entry Point Not Found
The procedure entry point mysql_stmt_prepare could not be located in the dynamic link library LIBMYSQL.dll

this is enough to crash apache , is this on a clean installation, and of wich a2t version ?
Back to top  
watchorn



Joined: 09 Mar 2007
Posts: 3
Location: Canada

Posted: Fri Mar 16, 2007 1:01 pm    Post subject: Re: Apache won't start, no error log messages  

Clean installation of version 1.5.4
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Fri Mar 16, 2007 1:17 pm    Post subject:  

can you do a system wide search for LIBMYSQL.dll and tell me it's locations ?
Back to top  
watchorn



Joined: 09 Mar 2007
Posts: 3
Location: Canada

Posted: Fri Mar 16, 2007 2:08 pm    Post subject:  

libmySQL.dll locations:

C:\WINDOWS\system32
C:\apache2triad\mysql\bin
Back to top  
Vlad Alexa Mancini



Joined: 07 Jul 2003
Posts: 1539

Posted: Sat Mar 17, 2007 10:36 am    Post subject:  

ok , well then in the most likely case that the two versions of the dll are not the same the error occurs because C:\WINDOWS\system32\libmySQL.dll is loaded instead of C:\apache2triad\mysql\bin\libmySQL.dll

i suggest you back up C:\WINDOWS\system32\libmySQL.dll and copy C:\apache2triad\mysql\bin\libmySQL.dll in C:\WINDOWS\system32\ or delete C:\WINDOWS\system32\libmySQL.dll alltogether if no other applications need it
Back to top  
 
       Apache2Triad Help, Support and Development Forum Index -> Apache2Triad Bugs
Page 1 of 1


Powered by phpBB Search Engine Indexer
Powered by phpBB 2.0.13 © 2001, 2002 phpBB Group