Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 SSLrequire
Google
Post new topic This topic is locked: you cannot edit posts or make replies.
Author Message
clapp528
 
 


Joined: 16 Jul 2004
Posts: 19

PostPosted: Fri Apr 29, 2005 3:24 pm Reply with quoteBack to top

this is my first time trying to setup SSL.. so bare with me

I hoping you can help me out with an apache problem



I thought i went through the appropriate steps to set this up but when i try and access it using Https i got page cannot be displayed

here is what i did
i created a key,a csr, and a crt

next i went in and created a website "secure.bobsdeli.com"

I set up the appropriate entries under virtualhost in my HTTPD.conf file

<VirtualHost 64.175.222.179 >
ServerAdmin webmaster@keyconn.net
DocumentRoot C:/apache2/htdocs/websites/bobsdeli/store
ServerName secure.bobsdeli.com
ErrorLog logs/secure.bobsdeli.com-error_log
CustomLog logs/secure.bobsdeli.com-access_log common
</VirtualHost>

i set up the appropriate entries in ssl.conf

<IfDefine>
<VirtualHost 64.175.222.179:443 >
ServerName secure.bobsdeli.com:443
ServerAdmin webmaster@keyconn.net
DocumentRoot c:/apache2/htdocs/websites/bobsdeli/store
ErrorLog c:/apache2/logs/ssl_error_bobsdeli.com
CustomLog c:/apache2/logs/ssl_access_bobsdeli.com"%t %{version}c %{cipher}c %{clientcert}c"
SSLEngine on
SSLCertificateFile C:/apache2/opssl/cert/secure.bobsdeli.com.crt
SSLCertificateKeyFile C:/apache2/opssl/bin/secure.bobsdeli.com.key
UserDir store
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>
</IfDefine>

when i run apachessl i dont get any errors
but when i try and go to its webiste httpS://secure.bobsdeli.com
nothing

any ideas why?
someone told me i might need a sslrequire statement for this to work

Sorry but i changed the IP address and the domain name
(i get paranoid sometimes)


Last edited by clapp528 on Fri Apr 29, 2005 4:25 pm; edited 1 time in total
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Apr 29, 2005 4:20 pm Reply with quoteBack to top

Try chaning your backslashes to forward slashes.

Code:
<IfDefine>
<VirtualHost 64.175.222.179:443 >
ServerName secure.bobsdeli.com:443
ServerAdmin webmaster@keyconn.net
DocumentRoot c:/apache2/htdocs/websites/bobsdeli/store
ErrorLog c:/apache2/logs/ssl_error_bobsdeli.com
CustomLog c:/apache2/logs/ssl_access_bobsdeli.com"%t %{version}c %{cipher}c %{clientcert}c"
SSLEngine on
SSLCertificateFile C:/apache2/opssl/cert/secure.bobsdeli.com.crt
SSLCertificateKeyFile C:/apache2/opssl/bin/secure.bobsdeli.com.key
UserDir store
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>
</IfDefine>


Make sure you have port 443 open on your firewall/router.

Test if you can access https://localhost/ (if you can't make sure you have apache2triad with ssl service running)
View user's profileSend private messageYahoo MessengerICQ Number
clapp528
 
 


Joined: 16 Jul 2004
Posts: 19

PostPosted: Fri Apr 29, 2005 4:26 pm Reply with quoteBack to top

i changed them..still nothing..
my router has port 443 open

https://localhost is working fine
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Fri Apr 29, 2005 4:47 pm Reply with quoteBack to top

see http://apache2triad.net/forums/viewtopic.php?t=1259

also your IfDefine lacks the parameter
http://httpd.apache.org/docs-2.0/mod/core.html#ifdefine
View user's profileSend private message
clapp528
 
 


Joined: 16 Jul 2004
Posts: 19

PostPosted: Fri Apr 29, 2005 4:53 pm Reply with quoteBack to top

<if defined ssl> is what i changed it to

still didn't work
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Apr 29, 2005 5:53 pm Reply with quoteBack to top

try
Code:
<VirtualHost *:443 >

instead of
Code:
<VirtualHost 64.175.222.179:443 >
View user's profileSend private messageYahoo MessengerICQ Number
clapp528
 
 


Joined: 16 Jul 2004
Posts: 19

PostPosted: Fri Apr 29, 2005 6:33 pm Reply with quoteBack to top

changing the <VirtualHost *:443 >
didn't work

but if i change this in my httpd.conf

VirtualHost 64.175.222.179 >
ServerAdmin webmaster@keyconn.net
DocumentRoot C:/apache2/htdocs/websites/bobsdeli/store
ServerName secure.bobsdeli.com

to

VirtualHost 64.175.222.179:80 >
ServerAdmin webmaster@keyconn.net
DocumentRoot C:/apache2/htdocs/websites/bobsdeli/store
ServerName secure.bobsdeli.com:80

i can somehow view the localhost website
any ideas why and how i can get it to point at the wbobsdeli webpage instead of the localhost?
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Fri Apr 29, 2005 7:10 pm Reply with quoteBack to top

clapp528 wrote:
<if defined ssl> is what i changed it to

still didn't work


are you trying to be funny , that is not even close to

Quote:
<IfDefine SSL>


and i gave you the link to a previous topic explaining this exact situation
View user's profileSend private message
Display posts from previous:      
Post new topic This topic is locked: you cannot edit posts or make replies.


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT