Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 phpPgAdmin 3.5.1 Login failed :(
Google
Post new topic Reply to topic
Author Message
gollum
 
 


Joined: 23 Apr 2005
Posts: 2

PostPosted: Tue May 10, 2005 5:04 am Reply with quoteBack to top

Hello!
sorry if this a silly question, but I have been trying to login to phpPgAdmin, but no matter what username and password I use, i just this:

I have even downloaded the latest version, apache2triad 1.5.2 silent update, and did a fresh install of it, but i still cannot login. Crying or Very sad

I then tryed to see if there was something wrong in "/guipgsql.php" or "/editor.php?load=pgsqlconf", but i found that everything was blank in both of them, and no matter what i put it would not save any changes...
Sad
Thanks in advance!
gollum
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Thu May 12, 2005 5:02 pm Reply with quoteBack to top

most likely you do not have a postgres cluster (it failed to initialise) so most likely the server is not even running , have you thought about checking that ?

did you get a console promt with "Enter password for apache2triad :" and have you entered the same password there that you entered in the installer ?

if so after entering the password in the console you should have see an lenghty (about 1 minute) pg database cluster initialization progress

if pgsql/data is empty it means that the initdb command runned as the apache2triad user just before the end of the installation was unsuccesfull and postgresql is not fully installed on your system

so either runas or initdb failed

reasons why initdb would fail include having a nonstandard locale , not having a NTFS file system , postgres utilises a feature called 'reparse points' to implement tablespaces which is not available on FAT partitions


reasons why runas would fail include not entering the same password you previously set in the installer , or your system's runas command requires special settings http://apache2triad.net/forums/viewtopic.php?t=2576
View user's profileSend private message
rickh57
 
 


Joined: 24 Dec 2004
Posts: 33

PostPosted: Thu May 12, 2005 7:48 pm Reply with quoteBack to top

By default, Postgresql is not configured to start automatically, so if your pgsql directories were created, you still need to make sure that the Apache2Triad PostgreSQL Service is running before trying to connect to it via phpPgAdmin.

(I ran into this just last evening and kicked myself once I realized that I'd forgotten to start Postgresql--and then immediately changed it to automatic startup!) Very Happy
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT