Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Noone can access ftp server
Google
Post new topic Reply to topic
Author Message
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Tue Jun 07, 2005 8:50 pm Reply with quoteBack to top

I've setup the ftp server (slimftp) and I can connect to it with a ftp client via 127.0.0.1 on port 21 and 1100 (one i made up to see if my isp blocks 21); but noone including myself can connect to it with the IP or the address ftp.evilweavil.com. My firewall and router are both setup to forward and allow connections on these ports. What should I try now?
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Wed Jun 08, 2005 1:34 am Reply with quoteBack to top

See if somethinging is listening on that port.

start->run->cmd.exe

then type:
Code:
netstat -an


see if you have anything listening on
0.0.0.0:21 or 127.0.0.1:21

if not then try and start it through A2T's CP http://localhost/apache2triadcp/ (or start->run->services.msc

if nothing is listening on port 21 and you try and start it but slimftp failes then check your config.

also I assume the address your trying is ftp://evilweavil.com and not ftp.evilweavil.com.
View user's profileSend private messageYahoo MessengerICQ Number
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Wed Jun 08, 2005 9:15 am Reply with quoteBack to top

ok now when i type in ftp://evilweavil.com:1100 it will try to connect to me on port 1100 since that is the ftp port i opened. Now I get this error mesage:

No connection could be made because the target machine actively refused it

but still with 127.0.0.1 i can login to the ftp server fine.

I even tried turning off the firewall and it didnt help.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Wed Jun 08, 2005 4:46 pm Reply with quoteBack to top

I assumed you did, but...
Quote:
see if you have anything listening on
0.0.0.0:1100 or 127.0.0.1:110

(sorry forgot to post it earlier.)
View user's profileSend private messageYahoo MessengerICQ Number
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Wed Jun 08, 2005 8:27 pm Reply with quoteBack to top

0.0.0.0:1100 listening
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Thu Jun 09, 2005 10:32 am Reply with quoteBack to top

check slimftpd.log to see if you are getting any connection attempts, if you are not getting connection attempts 1 of 2 things, port 21 is blocked, program not running. if you are getting connection attempts then the logs will tell you why you cant log in.

Unlike apache, there are very few things that can go wrong with slimftp ....
View user's profileSend private messageSend e-mailYahoo Messenger
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Thu Jun 09, 2005 11:44 am Reply with quoteBack to top

this is the info from smartftp

with firewall enabled
Code:

SmartFTP v1.1.985.6
    Resolving host name ftp.evilweavil.com...
    Connecting to (ftp.evilweavil.com) ->  IP: 66.57.98.55 PORT: 1100
    Connected to (ftp.evilweavil.com) -> Time = 94ms
    Socket connected waiting for login sequence.
    Connection timeout. No response from server.
    Active Help Link: http://www.smartftp.com/support/kb/index.php/58
    Cannot login waiting to retry (30s)...

with firewall disabled
Code:

Continue to login attempt 2...
    Connecting to (ftp.evilweavil.com) ->  IP: 66.57.98.55 PORT: 1100
    No connection could be made because the target machine actively refused it.
    Active Help Link: http://www.smartftp.com/support/kb/index.php/58
    Connection closed.

Connecting with 127.0.0.1 port 1100 connected fine... heres the info from the log file for slimftp
Code:

[6/9/2005 7:39:33 AM] [208] Incoming connection from localhost:2698.
[6/9/2005 7:39:33 AM] [208] User "fakeuser" logged in.
[6/9/2005 7:39:37 AM] [208] User "fakeuser" logged out.
[6/9/2005 7:39:37 AM] [208] Connection closed.


Using my ip instead of the url results in the samething
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Thu Jun 09, 2005 2:26 pm Reply with quoteBack to top

fsockopen(): unable to connect to ftp.evilweavil.com:1100
Port 1100 does not appear to be open.

you say slimftpd.exe listens on 0.0.0.0:1100
are you sure ? how did you determine this ? because you seem to be wrong

btw you might want to use totalcommander as a ftp client in order to get a actual log of the ftp connection (wincmd\ftplog.log)
View user's profileSend private message
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Thu Jun 09, 2005 8:09 pm Reply with quoteBack to top

Demoric wrote:
See if somethinging is listening on that port.

start->run->cmd.exe

then type:
Code:
netstat -an


see if you have anything listening on
0.0.0.0:21 or 127.0.0.1:21



Thats how i found out that its listening on port 1100. And i know that slimftp.exe is running becuase i can find it in the cntrl-alt-del menu
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Thu Jun 09, 2005 10:26 pm Reply with quoteBack to top

When I used to use slimftp, I had a problem with the config file. I had one user set wrong, and every user after it wouldn't work, but every user before would.

I fixed the error, and then everybody work.

My suggestion, check the config. If that is good then re-verify that your firewall settings.
View user's profileSend private messageYahoo MessengerICQ Number
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Fri Jun 10, 2005 2:54 am Reply with quoteBack to top

these are the only 2 users i have setup and they both work when connecting on 127.0.0.1

Code:

<User "root">
   Password "***********"
   Mount / C:\apache2triad\htdocs\
   Allow / All
</User>

<User "fakeuser">
        Password "***********"
        Mount / C:\apache2triad\htdocs\test\
        Allow / Read List
</User>


**Edit**

Ok I downloaded and installed Nofeel FTP Server and I get the same problem with that... Oddly enough I can disable XP's firewall, Nortrons firewall, McAfee's spamkiller and antiviruse and still cannot login with anything other then 127.0.0.1. It can't be a router issue becuase I know alot about my router and I know everything is forwarded correctly.
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Fri Jun 10, 2005 5:13 am Reply with quoteBack to top

you guys are so good at it it seems you could go on like this forever , no offence

can you not hear me that a connection can not be made on port 1100 to ftp.evilweavil.com

if the server is answering at that port the connection is obviously blocked or not forwarded


Last edited by Vlad Alexa Mancini on Fri Jun 10, 2005 10:46 am; edited 1 time in total
View user's profileSend private message
weavil
 
 


Joined: 16 Jun 2004
Posts: 21

PostPosted: Fri Jun 10, 2005 6:27 am Reply with quoteBack to top

Vlad Alexa Mancini wrote:
you guys are so good at it it seems you could go on like this forever , no offence

can you not hear me that a connection can not be made on port 1100 to ftp.evilweavil.com

if the server is answering at that port the connection is obviously blocked or not forwarded


How could it be if; 1 xp firewall is off, 2 norton is off, and 3 the ports are forwarded. Cmd says the ports are listening and since i've had this problem with a gameserver the feature Block WAN Request in the router is turned off. So in other words, theres NO reason it shouldn't work.
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Fri Jun 10, 2005 10:44 am Reply with quoteBack to top

weavil wrote:
theres NO reason it shouldn't work.


there is allways a reason , the fact that it does not work proves it

Quote:

root@xxxxxxxx:~# nmap ftp.evilweavil.com -v -p 80,113,8080,1100,10000
Starting nmap 3.50 ( http://www.insecure.org/nmap/ ) at 2005-06-10 13:59 EEST
Host cpe-066-057-098-055.triad.res.rr.com (66.57.98.55) appears to be up ... good.
Initiating SYN Stealth Scan against cpe-066-057-098-055.triad.res.rr.com (66.57.98.55) at 13:59
Adding open port 80/tcp
Adding open port 8080/tcp
The SYN Stealth Scan took 5 seconds to scan 5 ports.
Interesting ports on cpe-066-057-098-055.triad.res.rr.com (66.57.98.55):
PORT STATE
80/tcp open
113/tcp closed
1100/tcp filtered
8080/tcp open
10000/tcp filtered


as a 3rd party you can also use http://www.connectedgear.com/tools/ to verify


Last edited by Vlad Alexa Mancini on Fri Jun 10, 2005 11:06 am; edited 3 times in total
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Fri Jun 10, 2005 10:46 am Reply with quoteBack to top

to quote myself

Quote:
check slimftpd.log to see if you are getting any connection attempts, if you are not getting connection attempts 1 of 2 things, port 21 is blocked, program not running. if you are getting connection attempts then the logs will tell you why you cant log in.

Unlike apache, there are very few things that can go wrong with slimftp ....


Alex is right, there is always a reason for something.
View user's profileSend private messageSend e-mailYahoo Messenger
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT