Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 A slight problem with php mail
Google
Post new topic Reply to topic
Author Message
skindoze
 
 


Joined: 20 Apr 2005
Posts: 14

PostPosted: Sun Jun 19, 2005 8:35 am Reply with quoteBack to top

Hi A2T users..

I'm having a small problem and i hope someone here has the solution.
I'm running the latest version of A2T on Win XP Pro.
Almost everything is running smoothly except one..
I installed a php script called AShop, in which i intended to sell digital goods..
the system works like this :
buyer comes in to my website, selects a product he wishes to buy, clicks the buy now button, he is then taken to PayPal, he makes his payment and then the script is supposed to send him a download link in his mail..
Unfortunately the script is not sending him the download link to his mailbox of choice..
So i checked the script over and over to make sure everything is running properly, and i can find nothing wrong with it.

I then realised that maybe the fault lies with xmail
i checked all the xmail settings and found that it is able to send and receive emails..

So now i'm stuck with no place to go
i can't for the life of me figure out why my customers are not getting their email after making payments

Anybody have any ideas ?

Thanks in advance
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Sun Jun 19, 2005 5:20 pm Reply with quoteBack to top

most likely the program is using php mail() function, which does not have commands to enter user or password, need to open localhost for relay (AND ONLY LOCALHOST) or find setting in the program to use SMTP authentication ...
View user's profileSend private messageSend e-mailYahoo Messenger
skindoze
 
 


Joined: 20 Apr 2005
Posts: 14

PostPosted: Sun Jun 19, 2005 5:29 pm Reply with quoteBack to top

thanks for the reply Liquidsnake

but i don't understand what you mean
are there certain settings i must modify in certain files ?
if so, which files do i need to modify.
please explain as i am so lost

appreciate your help
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT