Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Apache Modules
Google
Post new topic Reply to topic
Author Message
Twirp
 
 


Joined: 07 May 2005
Posts: 14
Location: Md

PostPosted: Sat Oct 22, 2005 6:11 pm Reply with quoteBack to top

I installed Apache 2 Triad a while ago just to have PHP and MySQL (becuase i use Perl for other reasons)
So after a while, I decided i would learn ruby, and installed some stuff
And that added the line mod_fastcgi/2.4.2 mod_ruby/1.2.4 Ruby/1.8.2(2004-12-25)
So i thought mod_perl and mod_python and some other stuff was installed, but I wondered why it didn't show the lines.

And then I tried using perl and python, and whenever I went to a Perl, ASP, or Python file it showed the source.

I think it has something to do with the httpd.conf file, and did some playing with that, but couldn't get it to work.

So I was wondering if I could get some help
here's the section:
Code:

#CGI (perl/python/tcl) config
LoadModule cgi_module modules/mod_cgi.so
<IfModule mod_cgi.c>
AddHandler cgi-script .cgi
AddType application/x-httpd-cgi .cgi
AddHandler cgi-script .py
AddType application/x-httpd-cgi .py
AddHandler cgi-script .tcl
AddType application/x-httpd-cgi .tcl
</IfModule>

#perl config
LoadFile "G:\perl\bin\perl58.dll"
#LoadModule perl_module modules/mod_perl.so
<IfModule mod_perl.c>
Alias /perl/ "G:/perl/"
AddHandler perl-script .pl
AddType application/x-httpd-perl .pl
PerlOptions ParseHeaders
PerlHandler ModPerl::Registry
PerlSendHeader On
</IfModule>

#asp config
<IfModule mod_perl.c>
PerlModule Apache::ASP
PerlSetVar NoState 1
<Files ~ (\.asp)>
SetHandler perl-script
#PerlHandler Apache::ASP
PerlSetVar Global .
PerlSetVar StateDir "G:/apache2triad/temp"
</Files>
</IfModule>

#python config
LoadFile python\bin\python23.dll
#LoadModule python_module modules/mod_python.so
<IfModule mod_python.c>
  Alias /python/ "G:/apache2triad/python/"
  AddHandler python-program .spy
  PythonHandler run_spyceModpy::spyceMain
</IfModule>



On a side note, I did alot of playing with some of the files, do I have to upgrade, and if so, can I just copy the conf file, htdocs, and the mysql stuff, install 1.5.3, and then paste it over what was installed (except for phpmyadmin,pgadmin,and all etc.)?

Thanks for reading.
View user's profileSend private messageAIM AddressYahoo MessengerMSN Messenger
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Sat Oct 22, 2005 6:46 pm Reply with quoteBack to top

http://localhost/apache2triadcp/guihttpd.cgi
View user's profileSend private messageYahoo MessengerICQ Number
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT