Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Setting up slimftpd.conf with Tomcat
Google
Post new topic Reply to topic
Author Message
ahkuh
 
 


Joined: 04 Nov 2005
Posts: 3

PostPosted: Fri Nov 04, 2005 12:12 am Reply with quoteBack to top

Hi all,

I found this forum to be extremely helpful in solving other slimftp related problems. However, I have a specific question related to mounting Tomcat webapps folder to a new user.

I added a new user to slimftpd.conf file like so:

after root user

<User "username">
Password "*************"
Mount / C:\Program Files\Apache Software Foundation\webapps\genomics
Allow / All
</User>

This somehow creates a problem and it stops ftp service. Tomcat is linked to apache2triad server, but in order to run jsp files, I must put .jsp files in this webapps folder in differnt directory as indicated above. But it seems like I can't do it as above.

How can I let user access webapps folder outside of c:\apache2triad\*?

Can somebody help me out here?

Thanks in advance.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Nov 04, 2005 12:43 am Reply with quoteBack to top

Try

Mount / C:\Program Files\Apache Software Foundation\webapps\genomics\
or
Mount / "C:\\Program Files\\Apache Software Foundation\\webapps\\genomics"
or
Mount / C:/Program Files/Apache Software Foundation/webapps/genomics
View user's profileSend private messageYahoo MessengerICQ Number
ahkuh
 
 


Joined: 04 Nov 2005
Posts: 3

PostPosted: Fri Nov 04, 2005 12:51 am Reply with quoteBack to top

Thanks for the response, but none of the above suggestions worked...

[2005-11-03 ¿ÀÈÄ 7:49:21] SlimFTPd 3.17, by WhitSoft Development (www.whitsoftdev.com)
[2005-11-03 ¿ÀÈÄ 7:49:21] The SlimFTPd service is starting.
[2005-11-03 ¿ÀÈÄ 7:49:21] Executing "SlimFTPd.conf"...
[2005-11-03 ¿ÀÈÄ 7:49:21] Error on line 108: Mount directive should have exactly 2 arguments.
[2005-11-03 ¿ÀÈÄ 7:49:21] Failed parsing configuration script.
[2005-11-03 ¿ÀÈÄ 7:49:21] An error occurred while starting SlimFTPd.
[2005-11-03 ¿ÀÈÄ 7:49:21] The SlimFTPd service has stopped.


I get above errors...

Any other suggestions??
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Nov 04, 2005 1:01 am Reply with quoteBack to top

Mount / "C:\\Program Files\\Apache Software Foundation\\webapps\\genomics\\"
View user's profileSend private messageYahoo MessengerICQ Number
ahkuh
 
 


Joined: 04 Nov 2005
Posts: 3

PostPosted: Fri Nov 04, 2005 8:22 pm Reply with quoteBack to top

Thanks for yet another suggestion, but it didn't work.

Any other suggestions guys?
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Nov 04, 2005 11:52 pm Reply with quoteBack to top

I had a problem similiar to what you're having awhile back, and what it turned out was every user after the 1st mis-configured user wouldn't work. My suggestion verify all your user configurations.

Mount / C:\Program Files\Apache Software Foundation\webapps\genomics\

should work.

Just check to see that your mount folders have the trailing slash on them.
View user's profileSend private messageYahoo MessengerICQ Number
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT