Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 File Uploads
Google
Post new topic Reply to topic
Author Message
Bulldog
 
 


Joined: 30 Jan 2006
Posts: 4

PostPosted: Mon Jan 30, 2006 4:28 pm Reply with quoteBack to top

I have everything in my php.ini file set to allow 20 MB file uploads. But no matter what script I use to upload files, anything over 2 MB ends up corrupt. Does anyone know what the problem might be?

Thanks.
View user's profileSend private message
dawg
support
support


Joined: 11 Apr 2004
Posts: 180

PostPosted: Mon Jan 30, 2006 4:52 pm Reply with quoteBack to top

More than likely it is an issue with HTTP upload --

I would advise using FTP for anything large
View user's profileSend private message
Bulldog
 
 


Joined: 30 Jan 2006
Posts: 4

PostPosted: Mon Jan 30, 2006 7:25 pm Reply with quoteBack to top

I can understand why you would suggest that. But that would kind of defeat the purpose of the project management software If I can't upload the project related files. Is there any way around the HTTP upload problem....if that's what it is? Should I be able to change the script to utilize FTP rather than HTTP?

Thanks.
View user's profileSend private message
dawg
support
support


Joined: 11 Apr 2004
Posts: 180

PostPosted: Mon Jan 30, 2006 11:36 pm Reply with quoteBack to top

I amy have spoken too soon -- so check this:

http://ca.php.net/manual/en/ini.core.php#ini.post-max-size

post_max_size integer
Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize.

If memory limit is enabled by your configure script, memory_limit also affects file uploading. Generally speaking, memory_limit should be larger than post_max_size.

When an integer is used, the value is measured in bytes. You may also use shorthand notation as described in this FAQ .

If the size of post data is greater than post_max_size, the $_POST and $_FILES superglobals are empty. This can be tracked in various ways, e.g. by passing the $_GET variable to the script processing the data, i.e. <form action="edit.php?processed=1">, and then checking if $_GET['processed'] is set.

The issue may be with your connection tho --
I would try a speed test with the maximum size you can get.
View user's profileSend private message
Bulldog
 
 


Joined: 30 Jan 2006
Posts: 4

PostPosted: Tue Jan 31, 2006 6:55 pm Reply with quoteBack to top

Thanks for the reply. I found out that it is actually a download problem not an upload problem. The files on the server are the correct size and can be opened fine. But when downloaded they all become 1.90 MB.
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT