Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Given Path error message
Google
Post new topic Reply to topic
Author Message
Spannerman
 
 


Joined: 14 Oct 2006
Posts: 1

PostPosted: Sat Oct 14, 2006 10:14 pm Reply with quoteBack to top

Hi folks,

Can someone help me with this one please???

Have been trying to set up Virtual Hosts. Have been through every tutorial and post on this forum and on every other forum on the internet and am now really at the end of my tether.

Situation: I bought a dedicated server last week. It has Windows 2003 Server on it. I installed Apache2Triad after trying for 5 days to get my PHP / MySQL website working on IIS and on another distro of Apache etc.

Then I remembered A2T, which I have used years ago, so install and copy files to a subfolder in htdocs. Restore db to subfolder in mysql data folder.

I could access the site via www.farcanal.com/farcanal/ - and access cp via cp subfolder but this isn't secure and I wanted the farcanal site to be the one served as the root of the server. I also want to be able to host other sites on this server in future.

So, Virtual Hosts is the way to go - 2 days and I still haven't got it to work correctly.

I now have 403 "Forbidden" errors for both the site and the CP, but the logs created (named in the virtual hosts section of httpd.conf) hold the access and error messages.

Latest error message is :
Quote:
"(20023)The given path was above the root path: Cannot map GET /apache2triad/ HTTP/1.1 to file"


Here is the section of Virtual Hosts that is currently live:

Code:
NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin admin@localhost
DocumentRoot "c:\apache2triad\htdocs\"
ServerName localhost
DirectoryIndex index.php index.htm index.php3 index.html
ErrorLog logs/localhost_error.log
CustomLog logs/localhost_access.log common
<Directory "c:/apache2triad/htdocs/apache2triadcp/">
AllowOverride All
Options All Includes Indexes
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerAdmin admin@farcanal.com
DocumentRoot "c:\apache2triad\htdocs\farcanal"
ServerName www.farcanal.com
ServerAlias farcanal.com
ErrorLog logs/farcanal-error.log
CustomLog c:/apache2triad/logs/farcanal-access-log.log combined
<Directory "c:/apache2triad/htdocs/farcanal">
DirectoryIndex index.php index.htm index.php3 index.html
AllowOverride All
Options All Includes Indexes
</Directory>
</VirtualHost>


I really am at my wits end with this. Why is it so difficult to set up a Virtual Host???

BTW I have tried allsorts - / and \ in paths, names in " and without, paths starting c:\ and without. Virtualhost *, IP address, www.farcanal.com (which IS the domain name btw). All other paths in httpd.conf look to be correct as well - document root etc.

The Local Service account has full control of the A2T folder on the Windows box too.

What am I missing????

Any help much appreciated.

Simon

-------------------------------------------------

Update: Actually got the main site to work using a Virtual Host, but have now lost access to CP.

Main Site is on port 80, and would like access to the CP on another port - 81 is current choice, but getting 403 errors if I try to access it.

Have a second VirtualHost entry for port 81 and the Listen line for it, but no joy.

SSL and Email are the next things to look at too....
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT