Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Strange SSL error
Google
Post new topic Reply to topic
Author Message
NCH
 
 


Joined: 30 Oct 2006
Posts: 3

PostPosted: Fri Nov 03, 2006 8:09 pm Reply with quoteBack to top

I have created a custom self-signed SSL certificate using the tutorial and OpenSSL on A2T. A2T with SSL starts fine with no error messages as a service on XP. I have checked the logs and there are no new errors, other than "[error] VirtualHost *:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results" which I get every time but doesn't seem to cause any problems under http://localhost. However, when I go to https://localhost I get the following message:

localhost has sent an incorrect or unexpected message. Error code -12263.

Anyone have any ideas?

My certificate is not password protected.

Thank you.
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Sat Nov 04, 2006 11:40 am Reply with quoteBack to top

try an alternate browser
View user's profileSend private message
NCH
 
 


Joined: 30 Oct 2006
Posts: 3

PostPosted: Mon Nov 06, 2006 6:47 pm Reply with quoteBack to top

In IE it just fails to load after what seems like a browser timeout error. In Firefox I get a "server Timeout" error.

EDIT: Attached the httpd and ssl conf files. Any help would be appreciated.

A brief description:

I am hosting a few domains on different ports using vhost because my ISP blocks port 80. On one of these domains, "example1" I would like to be able to have https access as well. My ISP does not block 443. I have created a certificate using the tutorial and A2T with SSL starts fine as a service, but I am still getting the same error mentioned above.

Please share any thoughts you might have. I am new to this.
View user's profileSend private message
ericscampbell
 
 


Joined: 16 Jan 2007
Posts: 1
Location: Chicago

PostPosted: Tue Jan 16, 2007 10:04 pm Reply with quoteBack to top

I'm experiencing the same problem you are. I've created a self signed cert (in this case using an orielly tutorial).

Excerpt from error log:
Connection to child 0 established (server 127.0.0.1:443, client 127.0.0.1)
Seeding PRNG with 0 bytes of entropy

then I get either a time out or a disconnect error depending on which browser I'm using.

Also, under the httpd error_log, I'm seeing this error:
Invalid method in request
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT