Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Ubuntu Apache ignores .htaccess files!
Google
Post new topic Reply to topic
Author Message
invisible-root
 
 


Joined: 01 Jun 2007
Posts: 7

PostPosted: Fri Jun 01, 2007 7:50 am Reply with quoteBack to top

Hello!

I'm new to the forums and I need your help. The problem is that Apache completely ignores .htaccess files. I've installed apache on Ubuntu with PHP & SQL support.

In the apache2.conf file there's a line that includes other files from a specific folder in order to include configuration files for virtual hosts. Here's the line:

Code:

Include /etc/apache2/sites-enabled/


The above folder contains a file "default-000" with the following code:
Code:

NameVirtualHost *
<VirtualHost *>
   ServerAdmin webmaster@localhost
   ServerName localhost
   
   DocumentRoot /var/www/
   <Directory />
      Options +FollowSymLinks
      Options -Indexes
      AllowOverride None
   </Directory>
   <Directory /var/www/>
      Options +FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                #RedirectMatch ^/$ /apache2-default/
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.
   LogLevel warn

   CustomLog /var/log/apache2/access.log combined
   ServerSignature Off

</VirtualHost>


The solution to my problem is to set AllowOverride directive to "All". When I change the directive, I get "Internal Server Error" in all pages. Then I had a look in the error log:

Code:

[Thu May 31 08:35:56 2007] [notice] Apache/2.2.3 (Ubuntu) configured -- resuming normal operations
[Thu May 31 08:36:32 2007] [notice] caught SIGTERM, shutting down


I searched google about "caught SIGTERM" but I couldn't find a solution to this problem. The only thing I do is to modify "AllowOverride" directive to All:

Code:

AllowOverride All


This looks very complicated...

Thanks in advance.
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT