Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Allow outside mysql connections
Google
Post new topic Reply to topic
Author Message
uberamd
 
 


Joined: 25 Jan 2007
Posts: 1

PostPosted: Thu Jan 25, 2007 10:03 pm Reply with quoteBack to top

How do I configure MySQL to allow remote connections for username root? I have changed my bind IP but still no luck.

Thanks.
View user's profileSend private message
dale
 
 


Joined: 11 Jun 2006
Posts: 51
Location: las vegas, nv

PostPosted: Fri Jan 26, 2007 7:54 am Reply with quoteBack to top

If you are really sure that you want the whole world to get into your mysql as root, open up the firewall and routers/switches settings for port 3306.

A suggestion is that you make another user with limited permissions for your outside connections so that if someone connects as root they don't destroy your system.
View user's profileSend private message
seng
 
 


Joined: 02 Jun 2007
Posts: 2

PostPosted: Sat Jun 02, 2007 5:54 pm Reply with quoteBack to top

dale wrote:
If you are really sure that you want the whole world to get into your mysql as root, open up the firewall and routers/switches settings for port 3306.

A suggestion is that you make another user with limited permissions for your outside connections so that if someone connects as root they don't destroy your system.


I'm doing the same thing, but limiting to one server actually.

But the thing is port 3306 won't open on my computer... i've even taken the firewall off... my ISP might have disabled it on their end tho... anycase i'm using a different port now.

But my problem is that changing the bind-address causes phpmyadmin to deny access for any user and in this case root@myIP, which isn't good, also it won't allow my user@myIP which user should be allowed from any host.

when i switch back to localhost on the bind-address everything works properly again.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Sat Jun 09, 2007 6:43 pm Reply with quoteBack to top

try using a tunnel program like Stunnel. Just setup a secured connection between the client and host and you're set.

Or you can use a port forwarding program.
View user's profileSend private messageYahoo MessengerICQ Number
seng
 
 


Joined: 02 Jun 2007
Posts: 2

PostPosted: Sat Jun 09, 2007 11:10 pm Reply with quoteBack to top

actually i forgot i posted here, but i ended up getting it to work! ;p ok in reality i have no clue what actually happened b/c i did this before and it didn't work, but i tried it again and it worked... :S anyways, instead of switching ports to my remote desktop port 3389 [windows default] usually stays open. Doing so causes phpmyadmin to not be able to connect to the database at all!.... which defeats the purpose... i had to switch it back to port 3306.. then i had to switch the listen port to my ip, which then it wouldn't start up properly... :S [pointing it to a domain didn't work...] sooo i ended up commenting the bind-address out and it worked
#bind-address - [URL HERE]

'#' comments stuff out.

and it worked out fine. YAY.
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Sat Aug 04, 2007 11:34 am Reply with quoteBack to top

yep
Quote:
#bind-address 127.0.0.1
in my.ini is the setting that makes mysql to listen only localy , its in the FAQ too
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT