Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 R6034 error - possible curl.dll error
Google
Post new topic Reply to topic
Author Message
pademo57
 
 


Joined: 19 Mar 2008
Posts: 3

PostPosted: Wed Mar 19, 2008 3:19 am Reply with quoteBack to top

Yes, I'm a newbie. Got this error when I was trying to send input from a form and put it into MySQL database:

Program C;\apache2triad\PHP\bin\PHP.exe
R6034
An application has made an attempt to load the C runtime library incorrectly. Please contact the application support team for more info.

Next popup says:

PHP Startup: Unable to load dynamic library 'C:\apache2triad\php\extensions\php_curl.dll' - A dynamic link library (DLL) initialization routine failed.

I used this to try to connect:

(connect.php)
<?php
// hostname or ip of server
$servername='localhost';

// username and password to log onto db server
$dbusername='root';
$dbpassword='XXXXXXXXXX'; Not REALLY!!!

// name of database
$dbname='testdb';

connecttodb($servername,$dbname,$dbusername,$dbpassword);
function connecttodb($servername,$dbname,$dbuser,$dbpassword)
{
global $link;
$link=mysql_connect ("$servername","$dbuser","$dbpassword");
if(!$link){die("Could not connect to MySQL");}
mysql_select_db("$dbname",$link) or die ("could not open db".mysql_error());
}

I'm using PHP Version 5.1.2, MySQL is enabled (in fact, everything that I can see from the phpinfo says it all enabled). I was able to use phpMyAdmin 2.7.0-pl2 to create the database and insert a record.
The html, php files are all located in C:\apache2triad\htdocs

If I run the connect.php from a web browser it seems to work fine. But when I try to submit my data through my test.html form, which calls connect.php I get the above error. What am I doing wrong??? Please be gentle. Not sure if I have the right forum.

I should have stated that when I run connect.php from a web browser as long as I put http://localhost/connect.php, my connect.php seems to work fine.
View user's profileSend private message
jonesy3006
 
 


Joined: 12 Jun 2008
Posts: 1
Location: South Aus

PostPosted: Thu Jun 12, 2008 11:27 pm Reply with quoteBack to top

I am having the exact same 2 error messages come up when I try to open a php file by double clicking on it and when I click ok on the second one I get a black screen come for less than half a second before it disappears again, what can i do to fix this
View user's profileSend private message
pademo57
 
 


Joined: 19 Mar 2008
Posts: 3

PostPosted: Thu Jun 26, 2008 3:01 pm Reply with quoteBack to top

try looking at this post:

http://apache2triad.net/forums/viewtopic.php?t=4424
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT