Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Cannot start Apache Service
Google
Post new topic Reply to topic
Author Message
delixer
 
 


Joined: 23 Jul 2004
Posts: 1

PostPosted: Fri Jul 23, 2004 12:43 pm Reply with quoteBack to top

I don't know why this is happening. I thought it may be my configuration but I restored the default configuration so I don't think that is it. I am going to uninstall and reinstall after this post, but any suggestions would be appreciated.

"Windows could not start the Apache2Triad Apache2 Service on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service specific error code 1."
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Fri Jul 23, 2004 4:54 pm Reply with quoteBack to top

Do you have anything else running on port 80?? did you change anything in the config file?
View user's profileSend private messageSend e-mailYahoo Messenger
mipo
 
 


Joined: 20 Aug 2004
Posts: 2

PostPosted: Fri Aug 20, 2004 11:34 pm Reply with quoteBack to top

I have the same problem,please help me.

thank you LiquidSnake. problem was with port 80. I change it into 81, now everything is working
View user's profileSend private messageSend e-mail
mipo
 
 


Joined: 20 Aug 2004
Posts: 2

PostPosted: Fri Aug 20, 2004 11:40 pm Reply with quoteBack to top

thank you LiquidSnake. problem was with port 80. I change it into 81, now everything is working
View user's profileSend private messageSend e-mail
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Sat Aug 21, 2004 5:31 am Reply with quoteBack to top

running windows XP with SP2 by any chance ?
View user's profileSend private message
r0l0e
 
 


Joined: 24 Aug 2004
Posts: 4

PostPosted: Tue Aug 24, 2004 1:03 pm Reply with quoteBack to top

mancini wrote:
running windows XP with SP2 by any chance ?


yes i am and i wished i hadn't installed sp2. this is the message i get in the event viewer:

Quote:
The Apache service named Apache2Triad Apache2 Service reported the following error:
>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80


Quote:
The Apache service named Apache2Triad Apache2 Service reported the following error:
>>> no listening sockets available, shutting down


i'm sure other who are running sp2 will have the same errors. i hope this will be fixed soon.

ps. i don't have any other services running on port 80. i ran a port viewing app to double check this. i also don't have MS firewall enabled on this workstation since A2T is running inside my network with no access from outside.
View user's profileSend private message
r0l0e
 
 


Joined: 24 Aug 2004
Posts: 4

PostPosted: Tue Aug 24, 2004 1:16 pm Reply with quoteBack to top

i solved my problem. i went into httpd.conf and changed the Listen port 80 to port 8080 and apache started.
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Tue Aug 24, 2004 3:51 pm Reply with quoteBack to top

Quote:
i solved my problem. i went into httpd.conf and changed the Listen port 80 to port 8080 and apache started.


this is not the best way to do things, there is something else running on your defualt web server port. you should find out whats running on port 80 and resolve the issue that way. Did you have a previous web server installed?
View user's profileSend private messageSend e-mailYahoo Messenger
r0l0e
 
 


Joined: 24 Aug 2004
Posts: 4

PostPosted: Tue Aug 24, 2004 11:49 pm Reply with quoteBack to top

LiquidSnake wrote:

this is not the best way to do things, there is something else running on your defualt web server port. you should find out whats running on port 80 and resolve the issue that way. Did you have a previous web server installed?


yea i know. it does get annoying sometimes on the config side. i'll check what installed apps that may be running on port 80. maybe a streaming app is doing it's job somewhere in this workstation Very Happy

i didn't have any other web services running prior to installing A2T. a previouse version of A2t was removed 2 months ago because i was having problem with images not appearing. now i see that it has been resolved.
View user's profileSend private message
whitehawk
 
 


Joined: 27 Aug 2004
Posts: 8

PostPosted: Fri Aug 27, 2004 11:14 pm Reply with quoteBack to top

Check the "Listen " line.
Change it to Listen 80
or Listen 192.168.0.xx:80
or Listen domain.dom
Make sure you do not have any other decleration of "Listen " directive in httpd.conf

I run my server on Windows XP SP2 but so far no issues. I will be upgrading to apache2triad 1.3 in another 20 mins.. will get back with errors if any Rolling Eyes
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT