Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Always an old Perl version!
Google
Post new topic Reply to topic
Author Message
mapg
 
 


Joined: 22 Oct 2003
Posts: 12

PostPosted: Thu Dec 30, 2004 5:40 am Reply with quoteBack to top

I am sure that Mancini thinks that Perl is an obsolete application but he should be amazed to know how many developers use it.

Apache, and PHP are always update but Perl not. Perl 5.8.3 (what you are using now dated on February, 14th, 2004 instead of 5.8.6) implies i.e. that nobody is able to install easily latest versions of ImageMagick (bug fixed and running faster), implies that nobody is able to have the latest bugs fixed for Perl. Implies that nobody is able to keep a healthy server with less CPU and Memory usage with a modern perl version. Implies so many things that I do not know how you do not pay attention in this issue of Apache2Triad.

As ever, Mancini thinks that this is a play, and this is not a play but a very serious matter.

I would like to know where Mancini works. It's simply to recommend his chief to fire him. Nobody serious works like that. If you do not do the things well, I recommend to close this project and forget to play on Internet.

Mapg
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Thu Dec 30, 2004 10:09 am Reply with quoteBack to top

Well perl 5.8.3 does not have a security vulnerability like php 5.0.2 had , and tell you the truth , perl takes much time and work to update , a lot more than php my time being limited , and the last time i updated it was when you notified me about it and besides that virtually none of my users commented noting about perl . so you can understand why it is not a priority , still i will update it when the time comes.

If you are so strong however on regular perl updates , why dont you remind me to update it next time and do something constructive for a change .

oh and
mapg wrote:

By the way, is it very difficult to downgrade Perl 5.8 to 5.6.1 or Perl 5.6?

from http://apache2triad.net/forums/viewtopic.php?p=879&highlight=#879 this goes a bit against it doesn't it ?
View user's profileSend private message
LiquidSnake
past contributor
past contributor


Joined: 23 May 2004
Posts: 267
Location: Middlesboro, KY

PostPosted: Thu Dec 30, 2004 8:49 pm Reply with quoteBack to top

It's quite simple to upgrade Perl, or any module for that matter. Just plug it in and update accordingly.....
View user's profileSend private messageSend e-mailYahoo Messenger
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT