Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 PHP, MySQL, Apache Updates
Google
Post new topic Reply to topic
Author Message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Thu Aug 17, 2006 12:10 am Reply with quoteBack to top

Re-install A2T (or restore a backup folder of mysql if you made one.), or you can try other versions of mysql.


Last edited by Joshua Meadows (DemoRic) on Sat Aug 19, 2006 3:40 pm; edited 4 times in total
View user's profileSend private messageYahoo MessengerICQ Number
mastertr
 
 


Joined: 24 Jul 2006
Posts: 24

PostPosted: Thu Aug 17, 2006 7:01 am Reply with quoteBack to top

i already installed apache 2.2.2.
i will try mysql 5.1.5.
thanx.

(in your php5.2.0dev hack files, there is old installation phps files. i extracted the file and try installation and no success. the problem was .so files, i think)

-----------------------------------------------
errors
-----------------------------------------------
E:\mysql-max-5.1.5-alpha-win32>rename C:\WINDOWS\my.ini C:\WINDOWS\my.ini.bak
Komut sözdizimi yanlış. (command is wrong)

E:\mysql-max-5.1.5-alpha-win32>perl E:\mysql-max-5.1.5-alpha-win32\PhpIniUpdate.
pl
Argument "" isn't numeric in subroutine entry at E:\mysql-max-5.1.5-alpha-win32\
PhpIniUpdate.pl line 31.

and
"MySQLi entry not found will add entry"


----------fix--------------
rename %windir%\my.ini my.ini.bak
Win32::MsgBox('MySQLi entry not found will add entry.', '0');

but still there is still a php problem. i'll try reinstalling A2T

thanks a lot.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Aug 18, 2006 8:15 pm Reply with quoteBack to top

Thanks for the feedback on the script(s). Changes are implemented and ready for the next release of my quickhacks.

Apache 2.0 API, which has changed under Apache 2.2 will make php 5.2 not work on apache 2.2. Which is why mod_php won't work. However you can use php5apache2_2 from the current dev version. I'll add the mod_php file as an attachement.

*UPDATE* 2007.10.20
The mod_php that is the default in the Apache quickhack update is now the 5.2.x branch. However, the older 5.1.x file is included

I made some quick hack updates.
these are only for edge apache2triad releases


********
PHP 5.2.4
decompress the rar file
then run A2TPhpinstall.cmd
ftp://jaydium.servehttp.com/php-update-524.zip
********

********
MySQL 5.1.11 Beta
backup your databases
decompress the rar file
then run A2TMySQLinstall.cmd
ftp://jaydium.servehttp.com/mysql-5.1.11-beta-win32.rar
********

********
Apache 2.2.6
backup your apache2triad\bin and apache2triad\module folders
decompress the rar file
then run A2TApacheInstall.cmd
ftp://jaydium.servehttp.com/a2t154-httpd-2.2.6-win32-x86-ssl.zip
********


mod_php.rar
 Description:
mod_php.so (php5apache2_2.dll)

Download
 Filename:  mod_php.rar
 Filesize:  10 KB
 Downloaded:  1602 Time(s)



Last edited by Joshua Meadows (DemoRic) on Sun Oct 21, 2007 4:24 am; edited 1 time in total
View user's profileSend private messageYahoo MessengerICQ Number
mastertr
 
 


Joined: 24 Jul 2006
Posts: 24

PostPosted: Sat Aug 19, 2006 5:02 pm Reply with quoteBack to top

thanks for new hacks.

i have again a problem Very Happy

i run php5.1.5 and mysql5.1.11 hack files.
first this hack doesnt update php.ini.
php_mysql.dll isn't changed php_mysqli.dll
i changed that.
but in phpmyadmin home screen, i receive an error.
"cannot load MySQL extension, please check PHP Configuration"
help file says:

To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar.

so, what do you think about this error?
what should i do?
thanks again.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Sat Aug 19, 2006 6:30 pm Reply with quoteBack to top

You need both lines in your c:\windows\php.ini (also make certain it exists, it may have been renamed php.ini.bak)

Quote:
extension=php_mysql.dll
extension=php_mysqli.dll


After making those changes restart apache service.

I changed the distro to make a note to have the user manually add the entry.

If the php.ini.bak file is in the installer folder you can run the PhpIniUpdate.pl command to have it generate the php.ini file, but when it is called from inside the batch file, it won't create it in the installer folder. I think it has something to do with the current working directory and perl
View user's profileSend private messageYahoo MessengerICQ Number
mastertr
 
 


Joined: 24 Jul 2006
Posts: 24

PostPosted: Sun Aug 20, 2006 6:00 pm Reply with quoteBack to top

thanks a lot.
it works. Smile
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Sun Oct 21, 2007 4:29 am Reply with quoteBack to top

Thank you, too for your patience, and feedback.
View user's profileSend private messageYahoo MessengerICQ Number
DELETED
Guest





PostPosted: Sun Oct 28, 2007 12:04 pm Reply with quoteBack to top

DELETED
padamsn
 
 


Joined: 24 May 2005
Posts: 11

PostPosted: Mon Mar 03, 2008 3:35 am Reply with quoteBack to top

i was trying to get the newer version of php to hold me off untill either a full ap2t update comes out or i find a different up to date wamp

anyhow the links are dead and http://jaydium.servehttp.com/ appers to be off line

the no-ip domain isn't even registered as in use anymore
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT