Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 apache stops working and worker threads stop after restart
Google
Post new topic Reply to topic
Author Message
padamsn
 
 


Joined: 24 May 2005
Posts: 11

PostPosted: Thu Feb 02, 2006 6:46 pm Reply with quoteBack to top

apache stops working fue hours after startup and worker threads stop after a manual restart therafter 2nd time it has happend.

ok ile post the rellvent log entrys it explanes it best

[Tue Jan 17 22:40:42 2006] [notice] Child 2836: Process exiting because it reached MaxRequestsPerChild. Signaling the parent to restart a new child process.
[Tue Jan 17 22:40:43 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Tue Jan 17 22:40:44 2006] [notice] Child 2836: Released the start mutex
[Tue Jan 17 22:40:47 2006] [notice] Child 2836: Waiting for 150 worker threads to exit.
[Tue Jan 17 22:40:48 2006] [notice] Child 2836: All worker threads have exited.
[Tue Jan 17 22:40:48 2006] [notice] Child 2836: Child process is exiting
[Tue Jan 17 22:40:56 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.4 configured -- resuming normal operations
[Tue Jan 17 22:40:56 2006] [notice] Server built: Apr 27 2005 00:37:53
[Tue Jan 17 22:40:56 2006] [notice] Parent: Created child process 1808
[Tue Jan 17 22:41:02 2006] [notice] Child 1808: Child process is running
[Tue Jan 17 22:41:02 2006] [notice] Child 1808: Acquired the start mutex.
[Tue Jan 17 22:41:02 2006] [notice] Child 1808: Starting 150 worker threads.
[Wed Jan 18 14:23:42 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Wed Jan 18 14:23:42 2006] [notice] Child 1808: Exit event signaled. Child process is ending.
[Wed Jan 18 14:23:45 2006] [notice] Child 1808: Released the start mutex
[Wed Jan 18 14:23:50 2006] [notice] Child 1808: Waiting for 150 worker threads to exit.
[Wed Jan 18 14:23:50 2006] [notice] Child 1808: All worker threads have exited.
[Wed Jan 18 14:23:50 2006] [notice] Child 1808: Child process is exiting
[Wed Jan 18 14:24:00 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.4 configured -- resuming normal operations
[Wed Jan 18 14:24:00 2006] [notice] Server built: Apr 27 2005 00:37:53
[Wed Jan 18 14:24:00 2006] [notice] Parent: Created child process 2596
[Wed Jan 18 14:24:08 2006] [notice] Child 2596: Child process is running
[Wed Jan 18 14:24:08 2006] [notice] Child 2596: Acquired the start mutex.
[Wed Jan 18 14:24:08 2006] [notice] Child 2596: Starting 150 worker threads.
[Wed Jan 18 14:24:12 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Wed Jan 18 14:24:12 2006] [notice] Child 2596: Exit event signaled. Child process is ending.
[Wed Jan 18 14:24:12 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.4 configured -- resuming normal operations
[Wed Jan 18 14:24:12 2006] [notice] Server built: Apr 27 2005 00:37:53
[Wed Jan 18 14:24:13 2006] [notice] Parent: Created child process 1948
[Wed Jan 18 14:24:13 2006] [notice] Child 2596: Released the start mutex
[Wed Jan 18 14:24:14 2006] [notice] Child 1948: Child process is running
[Wed Jan 18 14:24:14 2006] [notice] Child 1948: Acquired the start mutex.
[Wed Jan 18 14:24:14 2006] [notice] Child 1948: Starting 150 worker threads.
[Wed Jan 18 14:24:14 2006] [notice] Child 2596: Waiting for 150 worker threads to exit.
[Wed Jan 18 14:24:14 2006] [notice] Child 2596: All worker threads have exited.
[Wed Jan 18 14:24:15 2006] [notice] Child 2596: Child process is exiting
[Wed Jan 18 14:25:21 2006] [notice] Parent: Received restart signal -- Restarting the server.
[Wed Jan 18 14:25:22 2006] [notice] Child 1948: Exit event signaled. Child process is ending.
[Wed Jan 18 14:25:22 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.4 configured -- resuming normal operations
[Wed Jan 18 14:25:22 2006] [notice] Server built: Apr 27 2005 00:37:53
[Wed Jan 18 14:25:22 2006] [notice] Parent: Created child process 1104
[Wed Jan 18 14:25:23 2006] [notice] Child 1948: Released the start mutex
[Wed Jan 18 14:25:23 2006] [notice] Child 1104: Child process is running
[Wed Jan 18 14:25:23 2006] [notice] Child 1104: Acquired the start mutex.
[Wed Jan 18 14:25:23 2006] [notice] Child 1104: Starting 150 worker threads.
[Wed Jan 18 14:25:24 2006] [notice] Child 1948: Waiting for 150 worker threads to exit.

is it just me or did thay just start up 1 second ago

[Wed Jan 18 14:25:24 2006] [notice] Child 1948: All worker threads have exited.
[Wed Jan 18 14:25:24 2006] [notice] Child 1948: Child process is exiting

server never started working
ok so then i realise that the website isnt working so i open apache control panal hit restart and this is happend

im not shure but it seams like im missing logg info form the 2 restarts prior to the stop and start at the end

i see its not working still so i look at the log and think thats odd that it exited the threads right after starting them so i try stopping the server and starting it back up after one min

[Wed Jan 18 21:18:49 2006] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Wed Jan 18 21:18:50 2006] [notice] Child 1104: Exit event signaled. Child process is ending.
[Wed Jan 18 21:18:51 2006] [notice] Child 1104: Released the start mutex
[Wed Jan 18 21:18:52 2006] [notice] Child 1104: Waiting for 150 worker threads to exit.
[Wed Jan 18 21:18:52 2006] [notice] Child 1104: All worker threads have exited.
[Wed Jan 18 21:18:52 2006] [notice] Child 1104: Child process is exiting
[Wed Jan 18 21:18:57 2006] [notice] Parent: Child process exited successfully.
[Wed Jan 18 21:19:58 2006] [notice] Apache/2.0.54 (Win32) PHP/5.0.4 configured -- resuming normal operations
[Wed Jan 18 21:19:58 2006] [notice] Server built: Apr 27 2005 00:37:53
[Wed Jan 18 21:19:58 2006] [notice] Parent: Created child process 2420
[Wed Jan 18 21:19:58 2006] [notice] Child 2420: Child process is running
[Wed Jan 18 21:19:58 2006] [notice] Child 2420: Acquired the start mutex.
[Wed Jan 18 21:19:59 2006] [notice] Child 2420: Starting 150 worker threads.


this is the 2nd time i have had to do this im gona contenu to investgate at its current pattern it will stop working sometime overnight or tomarow morning and ile half to do this agan sense i have just redone the server it has alot of broken links im working on but havent had time lately to fix but it seamd to happen after a bunch of missing links wer logged to the error log

srry bout the long log segments im hopping someoen has seen this befor and will know a fix.

update ive had no luck with figureing it out other than it happens after the server gets so much use.

im reposting this last time i was nearly asleap and didnt relise this would of ben a better place for it



added feb 02 06

i looked at the recent instanced of this and it became even more pusliing the last command the server did was starting 150 worker threads and after that it didnt work it appers that it got a max requests per child and then started a new set of threads
after witch it stoped working hour later i found out hit stop and then start and its up agan still not shure why this happens

heres the last line in access log right afterwitch it proceeded to stop working

219.157.111.161 - - [02/Feb/2006:12:18:47 -0600] "GET http://210.197.72.121/~mana_/prxjdg.cgi HTTP/1.1" 404 1218 "-" "Mozilla/4.0 (compatible; MSIE 6.01; Windows NT 5.0)"

this is even more boggling 210.157.111.161 has nothing to do with my network or isp ther is no ~mana_ folder or prxjdg.cgi anywhre on my server but it was the last get request made and it happend just befor it had a max chiled requests and stoped working
View user's profileSend private message
dawg
support
support


Joined: 11 Apr 2004
Posts: 180

PostPosted: Thu Feb 02, 2006 11:57 pm Reply with quoteBack to top

Are you firewalled?? I would advise checking your server.

It looks like you are being used as a proxy - or scanned as a proxy --

http://web.freerk.com/proxyjudge/prxjdg.htm

http://210.197.72.121/~mana_/prxjdg.cgi
View user's profileSend private message
padamsn
 
 


Joined: 24 May 2005
Posts: 11

PostPosted: Sat Feb 04, 2006 3:24 am Reply with quoteBack to top

ya after looking in to that it seams thats what thay wer trying but emdalty afterward apache stoped working as in serving the web page everything server side sugested it was running fine except no page could load

i am firewalled and the ports are apropreatly set up
i can serve the web page fine but sometimes apache will stop serving without giving any warning this is not a networking problem because the page will fail to load on teh server its self


im still pussled to why it would stop next time i get free time ile print out the apache config ive edited one befor ile see if i can spot anythign odd
but sense i havnet modded it any other than thrue the apache triad cp that would be a posablty

thanks

btw so far as i know by default apache cannot be used as a proxy is this correct?
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Thu Sep 28, 2006 11:16 am Reply with quoteBack to top

issue id FAQ #26
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT