Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 [error] (OS 10038)An operation was attempted on something th
Google
Post new topic Reply to topic
Author Message
psycroptic
 
 


Joined: 09 Mar 2006
Posts: 10

PostPosted: Thu Mar 09, 2006 9:54 am Reply with quoteBack to top

Ok i just installed the new version and i get this in the errors log many lines of it, and web pages dont load at all through the domain or through localhost

Quote:
[Thu Mar 09 09:52:45 2006] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 5544: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.


EDIT: Heres some more info...
Only one process (httpd.exe) is using port 80
OS is XP
512 DDR ram
and 3.6 GHZ P4HT
Please could you help with this ASAP
View user's profileSend private message
dawg
support
support


Joined: 11 Apr 2004
Posts: 180

PostPosted: Thu Mar 09, 2006 12:52 pm Reply with quoteBack to top

AcceptEx() is a Microsoft WinSock v2 API that provides some performance improvements over the use of the BSD style accept() API in certain circumstances. Some popular Windows products, typically virus scanning or virtual private network packages, have bugs that interfere with the proper operation of AcceptEx(). If you encounter an error condition like:

[error] (730038)An operation was attempted on something that is not a socket.: winnt_accept: AcceptEx failed. Attempting to recover.
you should use this directive to disable the use of AcceptEx().
View user's profileSend private message
psycroptic
 
 


Joined: 09 Mar 2006
Posts: 10

PostPosted: Thu Mar 09, 2006 12:57 pm Reply with quoteBack to top

nope all i get is about 18MB's worth of the line shown above, and i didnt get it with the previous edge release

EDIT: Could someone assist me with this please?
EDIT: In reply with your post AcceptEx is disabled by default
View user's profileSend private message
dawg
support
support


Joined: 11 Apr 2004
Posts: 180

PostPosted: Thu Mar 09, 2006 5:20 pm Reply with quoteBack to top

Do you have a firewall? is there another application listening on port 80?
View user's profileSend private message
psycroptic
 
 


Joined: 09 Mar 2006
Posts: 10

PostPosted: Thu Mar 09, 2006 5:31 pm Reply with quoteBack to top

Yes i am using the SAME firewall i was using with 1.5.3 and all the apache2triad applications can accept connections etc.... And as i stated in the first post there is only the apache listening on port 80
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Fri Mar 10, 2006 12:03 pm Reply with quoteBack to top

apache 2.0 != apache 2.2
edge is not stable

other than than waiting for more reports to corroborate your issue
View user's profileSend private message
BobDawg
 
 


Joined: 07 Feb 2006
Posts: 2
Location: Orange, CA

PostPosted: Sun Mar 12, 2006 5:03 am Reply with quoteBack to top

I have the exact same problem my error log is filled with 63mb of
Code:
[Sat Mar 11 18:41:54 2006] [error] (OS 10038)An operation was attempted on something that is not a socket.  : Child 832: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.


My Specs are:
Code:
       OS: WinXP Pro SP2
 Firewall: ZoneAlarm Internet Security Suite 6.1
Processor: AMD Sempron
   Memory: (2x) 512MB PC-3200 DDR-400 RAM


Previous Edge Worked Fine, is there a way I can get a copy of the 1.5.3 edge, if not, I might have it on my system somewhere.

-BobDawg Cool
View user's profileSend private messageAIM AddressYahoo MessengerMSN Messenger
bubbaque
 
 


Joined: 01 Apr 2006
Posts: 1

PostPosted: Wed Apr 05, 2006 12:13 pm Reply with quoteBack to top

I'm receiving the same error. My system is XP, ApacheTriad 1.5.4, Zone Alarm 6.1. It seems to be an incompatability with ZA being installed on the system. When I remove ZA, everything consistently starts up OK. With ZA installed, ApacheTriad only starts up OK about 10% of the time. When it fails, the error log grows to hundreds of MB.

Thanks
View user's profileSend private message
james
 
 


Joined: 18 Jul 2006
Posts: 9

PostPosted: Mon Jan 08, 2007 6:08 am Reply with quoteBack to top

I'm having the same exact problem. I have XP pro service pack 2, apache2triad 1.5.4, and zone alarm pro 6.0.631.003.

Peace!
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT