Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 Bugous php 4.4.2
Google
Post new topic Reply to topic
Author Message
razor7
 
 


Joined: 17 May 2006
Posts: 6

PostPosted: Wed May 24, 2006 7:22 pm Reply with quoteBack to top

Hello php 4.4.2 has a severe bug ( http://bugs.php.net/bug.php?id=36017 ) that iterrupts the execution of any fopen, fclose, fread,
file_get_contents etc with a remote file. And since apache2triad 1.4.4 comes with that version of PHP i guess:

How can I upgrade PHP to the last 4.4.x dev package? (the one that can be downloaded from php.net)


Thanks
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri May 26, 2006 12:16 am Reply with quoteBack to top

Pathways are different in the 4.x series than the 5.x but if you modify the paths in my php update batch script then it should work just fine for you.

*removed batch codecode

I'd do this myself but I only run the edge version. (I choose to develop and use scripts for the 5.x branch) This script stops apache copies the new files over the old php files and then runs services.msc


Last edited by Joshua Meadows (DemoRic) on Fri Jun 09, 2006 10:35 pm; edited 1 time in total
View user's profileSend private messageYahoo MessengerICQ Number
razor7
 
 


Joined: 17 May 2006
Posts: 6

PostPosted: Fri May 26, 2006 4:18 am Reply with quoteBack to top

Thanks a lot for your help.

I have installed apache2triad 1.4.4 that ships php 4.4.2, because of this I need to update.

┬┐Does the above instrucions fit for this version?

Thanks
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri May 26, 2006 8:04 pm Reply with quoteBack to top

by changing the appropriate php pathways, and the correct files for your .so files it should work just fine.

If modifying batch scripts isn't something you can do or are comfortable with, then if you'll give me a folder layout for php4, I can modify the script and repost it for you to test.
View user's profileSend private messageYahoo MessengerICQ Number
razor7
 
 


Joined: 17 May 2006
Posts: 6

PostPosted: Mon May 29, 2006 6:37 pm Reply with quoteBack to top

I will realyy appreciate the modified version to fit php 4.4.x

Thanks.

EDIT:
Please send me the modified batch file so I can upgrade to PHP 4.4.x and override that anoying problem


Thanks.
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Fri Jun 09, 2006 10:33 pm Reply with quoteBack to top

Quote:
c:\apache2triad\php
|
+--cli
| |
| |-php.exe -- CLI executable - ONLY for commandline scripting
|
+--dlls -- support DLLs required by some extensions
| |
| |-expat.dll
| |
| |-fdftk.dll
| |
| |-...
|
+--extensions -- extension DLLs for PHP
| |
| |-php_bz2.dll
| |
| |-php_cpdf.dll
| |
| |-..
|
+--mibs -- support files for SNMP
|
+--openssl -- support files for Openssl
|
+--pdf-related -- support files for PDF
|
+--sapi -- SAPI (server module support) DLLs
| |
| |-php4activescript.dll
| |
| |-php4apache.dll
| |
| |-php4apache2.dll
| |
| |-..
|
+--PEAR -- initial copy of PEAR
|
|
|-go-pear.bat -- PEAR setup script
|
|-..
|
|-php.exe -- CGI executable
|
|-..
|
|-php.ini-dist -- default php.ini settings
|
|-php.ini-recommended -- recommended php.ini settings
|
|-php4ts.dll -- core PHP DLL
|
|-...


is this the file structure for the 1.4.x php folder? What is the
LoadModule line in your httpd.conf file for php?
View user's profileSend private messageYahoo MessengerICQ Number
razor7
 
 


Joined: 17 May 2006
Posts: 6

PostPosted: Wed Jun 14, 2006 12:57 am Reply with quoteBack to top

php4ts.dll is located here "C:\apache2triad\bin"

and PHP config is this LoadModule php4_module modules/mod_php.so

I also have attached the conf file

Any help?

Thanks.

PS: How can i query php to tell me the current runing version?
View user's profileSend private message
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Wed Jun 14, 2006 10:11 pm Reply with quoteBack to top

http://localhost/apache2triadcp/info.php is the easiest way to find the version.
Yeah the info helps, I'll see about d/l the latest dev version and make that into a pack in a few days
View user's profileSend private messageYahoo MessengerICQ Number
razor7
 
 


Joined: 17 May 2006
Posts: 6

PostPosted: Wed Jun 14, 2006 10:28 pm Reply with quoteBack to top

you mean that you will publish a new apache2triad installation without the bugous PHP 4.4.2?
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT