Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 localhost doesn't display correct charset, but www host does
Google
Post new topic Reply to topic
Author Message
butlerps
 
 


Joined: 27 May 2006
Posts: 2

PostPosted: Thu Jun 08, 2006 6:01 am Reply with quoteBack to top

hi all
i've got an annoying problem with my localhost that i use for my website development in that it does not automatically send the greek character set charset=iso-8859-7 to the browser. if I display the webpage as a file ie file:///d:/apache2triad/web/greek.html then the browser detects the meta tag and greek is displayed correctly, but if i view the page through localhost ie http://localhost/web/greek.html i get garbage, and have to manually go to language select in the browser (firefox) to view the page correctly. Any ideas would be wellcomed.
thanks
Philip

p.s when i ftp the site to my host, the pages display the correct language, so that is why i figured that it could be related to apache config.
View user's profileSend private message
dale
 
 


Joined: 11 Jun 2006
Posts: 51
Location: las vegas, nv

PostPosted: Sun Jun 11, 2006 4:55 am Reply with quoteBack to top

change your httpd.conf

AddDefaultCharset ISO-8859-1

to

AddDefaultCharset ISO-8859-7

You might just get lucky.
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT