Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 problem, apache wont start
Google
Post new topic Reply to topic
Author Message
james
 
 


Joined: 18 Jul 2006
Posts: 9

PostPosted: Wed Jan 03, 2007 2:49 pm Reply with quoteBack to top

Im having a problem starting Apache2, or Apache2 SSL. I looked im my error log and I keep getting a constant repeating error.

[Wed Jan 03 06:25:11 2007] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 3024: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

I figured maybe it is a firewall problem, so I disabled it and tried to start apache again, and still I keep getting the same error. I then went into my router to see if the correct ports are opened, and all is good.

This problem all of a sudden cropped up, and I have never had this problem before. Any Idea's.

Peace Out!!
and Thanks!!
View user's profileSend private message
lku homer
 
 


Joined: 29 May 2006
Posts: 104

PostPosted: Sun Jan 07, 2007 2:31 am Reply with quoteBack to top

I'm not sure that firewalls have anything to do with starting Apache, so I am guessing that the problem is in your httpd.conf somewhere.
View user's profileSend private messageAIM AddressYahoo MessengerMSN MessengerICQ Number
james
 
 


Joined: 18 Jul 2006
Posts: 9

PostPosted: Sun Jan 07, 2007 6:55 am Reply with quoteBack to top

I just reinstalled Apache2triad, and Im still having the same problem. I made no changes to the httpd.conf file. It does now appear to be a firewall problem because after I reinstalled triad I had zone alarm up and that same continuous error in the error log appeared. Now after I shutdown zone alarm again, apache started with out a hitch. I then looked at my config in zone alarm's program control, and everything seems to be correct.

HELP!!!!!
View user's profileSend private message
lku homer
 
 


Joined: 29 May 2006
Posts: 104

PostPosted: Mon Jan 08, 2007 7:45 am Reply with quoteBack to top

If it is a firewall problem, I would check the Networking forum. I never had a problem with my firewall.
View user's profileSend private messageAIM AddressYahoo MessengerMSN MessengerICQ Number
Joshua Meadows (DemoRic)
support
support


Joined: 29 Dec 2004
Posts: 783
Location: S.E. Kansas

PostPosted: Tue Jan 09, 2007 12:07 am Reply with quoteBack to top

Did you try Win32DisableAcceptEx ?
View user's profileSend private messageYahoo MessengerICQ Number
james
 
 


Joined: 18 Jul 2006
Posts: 9

PostPosted: Tue Jan 09, 2007 2:17 am Reply with quoteBack to top

If your talking about the directive in the httpd.conf file, it says it is enabled.

<IfDefine AEX>
Win32DisableAcceptEx
</IfDefine>

am I supposed to this

#<IfDefine AEX>
#Win32DisableAcceptEx
#</IfDefine>

I dont think this problem has anything to do with the configuration file, I think that it has to do something with Zone Alarm pro, because I just uninstalled Zone Alarm, and apache worked. Now after I reinstalled ZA, I get the same problem.


Update: I solved the problem that I was having with the the continous error I was having upon apache startup, it was as simple of just upgrading my Zone Alarm pro from version 6.0.631.003 to version 6.5.737.000. I Guess there was a stability problem with Zone Alarm and apache.
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT