Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 How do I change the port number Xmail listens on?
Google
Post new topic Reply to topic
Author Message
mikespcs
 
 


Joined: 19 Oct 2005
Posts: 7

PostPosted: Thu Feb 01, 2007 5:45 pm Reply with quoteBack to top

I have seen this referenced a few times here and at the XMAIL forums, but nobody has actually said how to change xmail from listening on port 25, to listening on port 26.

Can someone please let me know how to do this?

Thanks!

Mike
View user's profileSend private message
dale
 
 


Joined: 11 Jun 2006
Posts: 51
Location: las vegas, nv

PostPosted: Sat Feb 03, 2007 5:50 am Reply with quoteBack to top

You can use regedit to change the command line startup of xmail. This is how I did it. I went to

\HKEY_LOCAL_MACHINE\SOFTWARE\GNU\Xmail and there were 3 keys

Modify the MAIL_CMD_LINE Key and add -Sp 26

26 = the port that you want your smtp server to listen on.

Before your key should look like this:
-Pl -Sl -Ql -Fl -Cl -Ll
Then add the space and -Sp 26
-Pl -Sl -Ql -Fl -Cl -Ll -Sp 26

Before using regedit you should backup your registry like microsoft suggests, and just like they say, use at your own risk.

Of course you are probably using a spam program that listens on the outside world on port 25, and you need your xmail to listen on another port. I just used 26 because it was close to it and is usable. You can use any port you want long as your spam program uses the same port to connect to it.

Restart your xmail service and do a netstat -an and you should have

Proto Local Address Foreign Address State
TCP 0.0.0.0:26 0.0.0.0:0 LISTENING

This means that your xmail server is now listening on port 26 and life is good.

Hope that this helps and good luck!
View user's profileSend private message
mikespcs
 
 


Joined: 19 Oct 2005
Posts: 7

PostPosted: Sun Feb 18, 2007 7:15 pm Reply with quoteBack to top

I tried this on 2 systems (the -Sp 26 in the registry) and despite restarting the service and rebooting, it still listens on 25.

Anyone got any more ideas?

UPDATE: NEVER MIND! As I typed this I realized you put in -Sp 26, and apparently -SP 26 and -sp 26 and -Sp 26 are not the same.

-Sp 26 works! -SP 26 and -sp 26 dont!
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT