Apache2Triad Help, Support and Development Forum Index Search Profile Log in to check your private messages Log in Register Memberlist Attachments Statistics Crew/Ranks Archive
 php_pdf.dll error unable to initialize module
Google
Post new topic Reply to topic
Author Message
lynx3521
 
 


Joined: 08 Oct 2007
Posts: 1

PostPosted: Mon Oct 08, 2007 6:12 am Reply with quoteBack to top

Dear all,
i' just installed apache2triad1.5.4 from sourforge.net
and i have downloaded php pecl from php.net/downloads to get php_pdf.dll
i've put the dll in the extensions directory n added the php with "extension=php_pdf.dll" and restart apache

during the restart process, this error message occured

---
PHP Startup: pdf: Unable to initialize module.
Module compiled with module API=20060613, debug=0, thread-safety=1
PHP compiled with module API=20050922, debug=0, thread-safety=1
These options need to match
------

could anyone explain what should i do?
i've look in this forum for the same problem, but i only get this http://apache2triad.net/forums/archive/o_t__t_4606__help-me-pls-with-pdflib.html
View user's profileSend private message
Vlad Alexa Mancini
lead developer
lead developer


Joined: 07 Jul 2003
Posts: 1539

PostPosted: Mon Oct 15, 2007 10:09 pm Reply with quoteBack to top

you need to download the extension for the php version you use
apache2triad 1.5.4 has php version 5.1.2
so on http://pecl4win.php.net/ext.php/php_pdf.dll you could try php-5.1.6 (5_1)
View user's profileSend private message
Display posts from previous:      
Post new topic Reply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Powered by phpBB © 2001, 2002 phpBB Group :: FI Theme
All times are GMT